MiKrotik puede ser mas complicado de lo que parece. Parte 1

Estoy substituyendo un router veterano un  Linksys wrt54g con dd-wrt que tiene un colega en un bar. Este router funciona bien y hace lo que tiene que hacer. Solo que se queda un poco pillado por potencia y además de ser un cuello de botella ya que es solo 10/100.

Mirando por foros y viendo los problemas de substituir el router de diferentes compañías por culpa de la televisión en fibra acabe descubriendo los MiKrotik.

Así que por ahora vamos a hacer una substitución del Linksys por el Mikrotik sin tocar el router la de compañía. Después posiblemente le añadamos las Vlans correspondientes y procederemos a su substitución.

Hay que tener en cuenta como nos llega el Internet.

                *Si es ADSL u ONO (seudofibra). El router lo configuramos en modo bridge. (buscar manual para cada router especifico).

                *Si es fibra. La fibra entra en la ONT y de ahi sale un cable de red a un router de la compañía. Donde dicho router se puede poner en bridge o no dependiendo de si tiene que tener Vlans para la TV o no. Si se puede poner en bridge, lo ponemos, sino, lo que haces es un DMZ al router nuestro(Linksyso Microtik).

 

Para poneros en situación, la configuración en el bar actualmente es la siguiente:

ONO-Vodafone: Con seudofibra por lo que tenemos solo un router de la compañía. Este lo ponemos en modo bridge para darnos Internet sin ningún filtro a nuestro router.

Router Linksys que substituiremos por un Mikrotic del cual solo usamos  2 bocas.

                La boca 2 sera la Wan de estrada. (no usamos la 1 por ser la que es POE por si en un futuro la usásemos para algo).

                La boca 5 es la salida Trunk (donde tendremos 3 Vlans con sus DHCPs correspondientes)

                La boca 1 con IPs 192.168.100.x con Internet.

                La boca 3 con IPs 192.168.100.x con Internet.

                La boca 4 con IPs 192.168.100.x con Internet.

 

Swich gestionable de 16 bocas para distribuir la red. Donde tenemos la siguiente configuración.

Boca 1 en modo Trunk conectado a la boca 5 del router por este cable viene las 3 vlans.

Boca 2 en modo Trunk también para conectar el Ubiquiti (un AP de Wifi muy bueno) por aquí pasan también las 3 vlans.

Boca 3-5 para la Vlan3 de Gestión (Internet y red de TPV) ips de rango 192.168.103.x Los bocas(puertos) están configurados en modo Access. (es decir todo lo que enchufas en esta boca lo considera de la Vlan 3)

Boca 6-8 para la Vlan 4  que es para solo Internet de invitados (con algun control de no porno o no Facebook) y con IPs de este rango192.168.104.x en modo Access.

Boca 9-16 para la Vlan2 que son los puestos TPV(las cajas registradoras) e impresoras de tickets en red. Con IPs de rango 192.168.102.x en modo Access.

 

Dibujo muy simple en paint para explicarlo

 

 

 

Como vamos a proceder. Pues por partes para que todo el mundo pueda aprovechar esto. O parte del mismo para su proyecto.

Primero reseteamos el router por completo. Y borramos la configuración que viene por defecto.

 

 

Reseteo del MiKrotik

Manual completo aquí.

http://www.inkalinux.com/foros/showthread.php?111-5-Preparando-y-configurando-las-ethernet-en-RouterBoard-RB750-y-x86

 

Se puede hacer de varias formas desde el wimbox se haría en Quick Set y pulsamos donde pone Reset Configuración.

 

 

 

O desde línea de comando

Comando à system reset

Después cuando volvemos a abrir el Winbox saldría esto.

 

Es la pantalla del Winbosx de cero y lo primero que nos pregunta es si queremos que nos instala un script de configuración básica.

Como dichos parámetros no los sabemos esactos. Mejor en blanco y vamos viendo uno a uno todos esos parámetros. Por lo que pulsaremos donde pone Remove Configuration.

Vale con esto dejamos el Mikrotik sin nada de configuración. Perfecto para empezar.

Así es como quedaría en la menú de Interface List.

 

 

Paso primero, convertimos el router Microtik en un router Neutro.

Recomiendo leer esta parte del manual de Rojocesar.

http://www.inkalinux.com/foros/showthread.php?119-6-Configurando-las-tarjetas-de-red-WAN-y-LAN-para-tener-internet-desde-el-Mikrotik

Yo uso el Microtik 951G-2Hnd y la boca 1 esta reservada para POE.

Por lo que usare la boca 2 como la WAN y el resto para que nos del IPs del rango 192.10.10x y que tengan acceso a Internet.

Perfectamente podríamos usar otra boca como WAN como la 3, 4, o 5.

 

Lo primero que voy a hacer es renombrar las bocas del Microtik De esta forma.

La boca 1 la renombro a "1-POE"

La boca 2 la renombro a "2-WAN" Por donde conectaremos el router de la compañía.

La boca 3 la renombro a "3-ether"

La boca 4 la renombro a "4-ether"

La boca 5 la renombro a "5-Trunk" Por donde conectaremos el Swich Gestionable.

No es necesario renombrarlas, pero para mi es mas cómodo visualmente.

Además todas las bocas menos la 2 (la 2-WAN) la ponemos que dependan de la boca 2 es decir son esclavos de esa boca master. Para poder hacer esto solo hay que pinchar en cada una de las bocas y podemos renombrarlas y donde pone Master-Port marcamos que será la 2-WAN.

 

Código:

/interface ethernet

set [ find default-name=ether2 ] name=2-WAN

set [ find default-name=ether1 ] master-port=2-WAN name=1-POE

set [ find default-name=ether3 ] master-port=2-WAN name=3-ether

set [ find default-name=ether4 ] master-port=2-WAN name=4-ether

set [ find default-name=ether5 ] master-port=2-WAN name=5-Trunk